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Features of ms-excel 

1. Hyperlink. We can link one file to another file or page. 

2. Clip art. We can add images and also audio and video clips. 

3. Charts. With charts, we can clearly show a product(s) evaluation to a client. For example, you can 

display a chart showing which product is selling more or less by month, week, and so forth. 

4. Tables. Tables are created with different fields (e.g. name, age, address, roll number, and so forth). 

You can add a table to fill these values. 

5. Functions. There are both mathematical functions (add, subtract, divide, multiply), and logical ones 

(average, sum, mod, product). 

6. Images and backgrounds. You can incorporate images and backgrounds into each sheet. 

7. Macros. Macros are used for recording events for future use. 

8. Database: With the data feature, you can add any database from other sources to it. 

9. Sorting and filtering. We can sort and/or filter our data so that anything redundant or repetitive can be 

removed more easily. 

10. Data validations. This tool can helps you to enter valid data into your spreadsheet.  

11. Data consolidation. This tool helps you to consolidate your data of different spreadsheets. 

12. Grouping. The grouping feature helps you both to group your data and ungroup it so that you have 

subtotals and so forth. 

13. Page layout. Themes, colors, sheets, margins, size, backgrounds, breaks, print, titles, sheets height, 

width, scaling, grids, headings, views, bring to front of font or back alignment, and many more are 

available for you to lay out your page. 

 

Worksheet 

An Excel worksheet is a single spreadsheet that contains cells organized by rows and columns. A worksheet 

begins with row number one and column A. Each cell can contain a number, text or formula. A cell can also 

reference another cell in the same worksheet, the same workbook or a different workbook. In Excel 2010, the 

maximum size of a worksheet is 1,048,576 rows by 16,384 columns. 

Workbook 

A workbook is an Excel file that contains one or more worksheets. Each of the workbook and worksheets are 

in separate tabs on the bottom of the Excel window. By default, a new Excel workbook will contain three 

worksheets. You can switch between worksheets by clicking on the worksheet tab on the bottom of the Excel 

window. In Excel 2010 the number of worksheets in workbooks is limited only by your computer available 

memory. 

Definition of worksheet and workbook 

A work book is the ms-excel file in which you enter and store related data. A worksheet (also known as a 

spreadsheet) is a collection of cells on a single sheet where you can actually keep and manipulate the data. 

Each workbook can contain many worksheets. 

 

Benefits of Multiple Worksheets 

The ability to have multiple worksheets in an Excel workbook allows you to organize your data. Each 

worksheet can contain a different set of data. For example, one worksheet can contain your business sales data, 

a second can contain your inventory and a third can contain your expenses. 

 



 

Adding and Renaming Worksheets 

To add a new worksheet, click on the plus sign next to the last worksheet tab. A new blank worksheet will be 

created. Alternatively, you can click on "Sheet" under "Insert" on the top menu bar of Excel. To change the 

name of a worksheet right click on a worksheet tab, select "rename" and type in a new name followed by the 

Enter key. 

 

Printing Worksheets and Workbooks 

Excel gives you the option of printing a single worksheet or the entire workbook. To print a single worksheet 

select "Print" in the File menu then click the radio button next to "Active Worksheet" under the heading "Print 

what." To print the entire workbook, choose the radio button next to "Entire Workbook." 

Labeling 

The term label has a number of meanings in spreadsheet programs. A label most often refers to a text entry 

such as a heading used to identify a column of data. The term is also used to refer to the headings and titles in 

charts - such as the horizontal and vertical axis titles. 

LABELS IN EXCEL 

In versions of Excel up to Excel 2003, labels could also be used in formulas to identify a range of data. The 

label was the column heading and by entering it into a formula, the data beneath the heading would be taken as 

a range of data for the formula. 

 

Using labels in formulas was very similar to using named ranges. 

Named ranges, or defined names as they are also called, can still be used in the newer versions of Excel, have 

the advantage of allowing you to define a name for any cell or group of cells in a worksheet regardless of 

location. 

 

In the past, the term label was used to define a type of data used in spreadsheet programs. This use has been 

largely replaced by the term text data although certain functions in Excel, such as the CELL function still make 

reference to label as a type of data. 

To add, delete, worksheet we have options like to right click the mouse and select insert option or by selecting 

the same option under Home menu. To save we use short cut key Ctrl+S.   

These are same like insert, delete, and rename options.  

 

Format sheet tabs 

Select the data in the cell and click on format in menu bar or conditional formatting, in that select new rule in 

that select the features 2color /3color scale and accept. 

Format Worksheet Tab You can rename a worksheet or change the color of the tabs to meet your needs. To 

rename a worksheet: • Open the sheet to be renamed • Click the Format button on the Home tab • Click 

Rename sheet • Type in a new name • Press Enter 

3 ways to rename a worksheet 

1. Double-click the sheet tab, and type the new name. 

2. Right-click the sheet tab, clicks Rename, and type the new name. 

3. Use the keyboard shortcut Alt+H > O > R, and type the new name. 
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Reposition Worksheets in a Workbook 

To move worksheets in a workbook: • Open the workbook that contains the sheets you want to rearrange • 

Click and hold the worksheet tab that will be moved until an arrow appears in the left corner of the sheet • 

Drag the worksheet to the desired location 

 

Print a worksheet or workbook 

You can print entire or partial worksheets and workbooks, one at a time, or several at once. And if the data that 

you want to print is in a Microsoft Excel table, you can print just the Excel table.  

You can also print a workbook to a file instead of to a printer. This is useful when you need to print the 

workbook on a different type of printer from the one that you originally used to print it. 

Before you print anything in Excel, do remember that there are many options available for an optimal print 

experience.  

1. Select the worksheets that you want to print.  

2. Click File, and then click Print, press Ctrl+P. 

3. Click the Print button or adjust Settings before you click the Print button. 

Print one or several workbooks 

1. All workbook files that you want to print must be in the same folder. 

2. Click File, and then click Open. 

3. Hold down Ctrl and then click the name of each workbook that you want to print, and then click Print. 

 

Print all or part of a worksheet 

1. Click the worksheet, and then select the range of data that you want to print. 

2. Click File, and then click Print. 

3. Under Settings, click the arrow next to Print Active Sheets and select the appropriate option. 

4. Click Print. 

Print an Excel table 

1. Click a cell within the table to enable the table. 

2. Click File, and then click Print. 

3. Under Settings, click the arrow next to Print Active Sheets and select Print Selected Table. 

4. Click Print. 

Print a workbook to a file 

1. Click File, and then click Print, or press Ctrl+P. 

2. Under Printer, select Print to File. 

3. Click Print. 

4. In the Save Print Output As dialog box, enter a file name and then click OK. The file will be saved in 

your Documents folder 

 



FORMATTING WORKSHEET 

Keyboard shortcuts in excel  

Arrow keys One cell in the direction of the arrow 

Tab One cell to the right 

Shift+Tab One cell to the left 

Ctrl+arrow key To the edge of the current data region (the first or last cell that isn’t empty) in the direction 

of the arrow 

End To the cell in the lower-right corner of the window* 

Ctrl+End To the last cell in the worksheet, in the lowest used row of the rightmost used column 

Home To the beginning of the row containing the active cell 

Ctrl+Home To the beginning of the worksheet (cell A1) 

Page Down One screen down 

Alt+Page Down One screen to the right 

Ctrl+Page 

Down 

To the next sheet in the workbook 

Page Up One screen up 

Alt+Page Up One screen to the left 

Ctrl+Page Up To the previous sheet in the workbook 

Protect a worksheet 

To prevent other users from accidentally or deliberately changing, moving, or deleting data in a worksheet, you 

can lock the cells on your Excel worksheet and then protect the sheet with a password. Say you own the team 

status report worksheet, where you want team members to add data in specific cells only and not be able to 

modify anything else. With worksheet protection, you can make only certain parts of the sheet editable and 

users will not be able to modify data in any other region in the sheet. 

Choose what cell elements you want to lock. Here's what you can lock in an unprotected sheet: 

 Formulas: If you don’t want other users to see your formulas, you can hide them from being seen in 

cells or the Formula bar.  

 Ranges: You can enable users to work in specific ranges within a protected sheet.  



Enable worksheet protection 

Worksheet protection is a two-step process: the first step is to unlock cells that others can edit, and then you 

can protect the worksheet with or without a password. 

Step 1: Unlock any cells that needs to be editable 

1. In your Excel file, select the worksheet tab that you want to protect. 

2. Select the cells that others can edit. 

3. Right-click anywhere in the sheet and select Format Cells (or use Ctrl+1, or Command+1 on the 

Mac), and then go to the Protection tab and clear Locked. 

Step 2: Protect the worksheet 

Next, select the actions that users should be allowed to take on the sheet, such as insert or delete columns or 

rows, edit objects, sort, or use AutoFilter, to name a few. Additionally, you can also specify a password to lock 

your worksheet. A password prevents other people from removing the worksheet protection—it needs to be 

entered to unprotect the sheet. 

Given below are the steps to protect your sheet. 

1. On the Review tab, click Protect Sheet. 

2. In the Allow all users of this worksheet to list, select the elements you want people to be able to 

change. 

Option Allows users to 

Select locked 

cells 

Move the pointer to cells for which the Locked box is checked on the Protection tab of the 

Format Cells dialog box. By default, users are allowed to select locked cells. 

Select 

unlocked 

cells 

Move the pointer to cells for which the Locked box is unchecked on the Protection tab of 

the Format Cells dialog box. By default, users can select unlocked cells, and they can press the 

TAB key to move between the unlocked cells on a protected worksheet. 

Format cells Change any of the options in the Format Cells or Conditional Formatting dialog boxes. If you 

applied conditional formatting before you protected the worksheet, the formatting continues to 

change when a user enters a value that satisfies a different condition. 

Format 

columns 

Use any of the column formatting commands, including changing column width or hiding 

columns (Home tab, Cells group, Format button). 

Format rows Use any of the row formatting commands, including changing row height or hiding rows 

(Home tab, Cells group, Format button). 

Insert 

columns 

Insert columns. 

Insert rows Insert rows. 

Delete rows Delete rows. 

 

Sort Use any commands to sort data (Data tab, Sort & Filter group). 



Option Allows users to 

 

Use 

AutoFilter 

Use the drop-down arrows to change the filter on ranges when AutoFilters are applied. 

 

Use 

PivotTable 

reports 

Format, change the layout, refresh, or otherwise modify PivotTable reports, or create new 

reports. 

Edit objects Doing any of the following: 

o Make changes to graphic objects including maps, embedded charts, shapes, text 

boxes, and controls that you did not unlock before you protected the worksheet. For example, if 

a worksheet has a button that runs a macro, you can click the button to run the macro, but you 

cannot delete the button. 

o Make any changes, such as formatting, to an embedded chart. The chart continues 

to be updated when you change its source data. 

o Add or edit comments. 

Edit 

scenarios 

View scenarios that you have hidden, making changes to scenarios that you have prevented 

changes to, and deleting these scenarios. Users can change the values in the changing cells, if the 

cells are not protected, and add new scenarios. 

3. Optionally, enter a password in the Password to unprotect sheet box and click OK. Reenter the 

password in the Confirm Password dialog box and click OK 

 

Sorting Data 

As you add more content to a worksheet, organizing this information becomes especially important. You can 

quickly reorganize a worksheet by sorting your data. For example, you could organize a list of contact 

information by last name. Content can be sorted alphabetically, numerically, and in many other ways. 

Types of sorting 

When sorting data, it's important to first decide if you want the sort to apply to the entire worksheet or just 

a cell range. 

Sort sheet organizes all of the data in your worksheet by one column. Related information 

across each row is kept together when the sort is applied. In the example below, the Contact 

Name column (column A) has been sorted to display the names in alphabetical order. 



 

 

 

 Sort range sorts the data in a range of cells, which can be helpful when 

working with a sheet that contains several tables. Sorting a range will not 

affect other content on the worksheet. 

 

To sort a sheet: In our example, we'll sort a T-shirt order form alphabetically 

by Last Name (column C). 



1. Select a cell in the column you want to sort by. In our example, we'll select cellC2. 

 

2. Select the Data tab on the Ribbon, then click the A-Z command to sort A to Z, or the Z-A 

command to sort Z to A. In our example, we'll sort A to Z. 

 

3. The worksheet will be sorted by the selected column. In our example, the worksheet is now sorted 

by last name. 

 



To sort a range: In our example, we'll select a separate table in our T-shirt order form to sort the number of 

shirts that were ordered on different dates. 

1. Select the cell range you want to sort. In our example, we'll select cell rangeG2:H6. 

 

2. Select the Data tab on the Ribbon, and then click the Sort command. 

 

3. The Sort dialog box will appear. Choose the column you want to sort by. In our example, we want to 

sort the data by the number of T-shirt orders, so we'll select Orders. 

 



4. Decide the sorting order (either ascending or descending). In our example, we'll use Largest to 

Smallest. 

5. Once you're satisfied with your selection, click OK. 

 

6. The cell range will be sorted by the selected column. In our example, the Orders column will be sorted 

from highest to lowest. Notice that the other content in the worksheet was not affected by the sort. 

 

If your data isn't sorting properly, double-check your cell values to make sure they are entered 

into the worksheet correctly. Even a small typo could cause problems when sorting a large 

worksheet. In the example below, we forgot to include a hyphen in cell A18, causing our sort 

to be slightly inaccurate. 



 

Custom sorting: Sometimes you may find that the default sorting options can't sort data in the order you 

need. Fortunately, Excel allows you to create a custom list to define your own sorting order. 

To create a custom sort: 

In our example below, we want to sort the worksheet by T-Shirt Size (column D). A regular 

sort would organize the sizes alphabetically, which would be incorrect. Instead, we'll create a 

custom list to sort from smallest to largest. 

1. Select a cell in the column you want to sort by. In our example, we'll select cellD2. 

 

2. Select the Data tab, and then click the Sort command. 

 



3. The Sort dialog box will appear. Select the column you want to sort by, and then choose Custom 

List... from the Order field. In our example, we will choose to sort by T-Shirt Size. 

 

4. The Custom Lists dialog box will appear. Select NEW LIST from the Custom Lists: box. 

5. Type the items in the desired custom order in the List entries: box. In our example, we want to sort our 

data by T-shirt size from smallest to largest, so we'll type Small, Medium, Large, and X-Large, 

pressing Enter on the keyboard after each item. 

 

6. Click Add to save the new sort order. The new list will be added to the Custom lists: box. Make sure 

the new list is selected, and then click OK. 



 

7. The Custom Lists dialog box will close. Click OK in the Sort dialog box to perform the custom sort. 

 

8. The worksheet will be sorted by the custom order. In our example, the worksheet is now organized by 

T-shirt size from smallest to largest. 



 

     Sorting levels: If you need more control over how your data is sorted, you can add multiple levels to any sort. 

This allows you to sort your data by more than one column. 

To add a level: 

In our example below, we'll sort the worksheet by T-Shirt Size (Column D), and then by 

Homeroom Number (column A). 

1. Select a cell in the column you want to sort by. In our example, we'll select cellA2. 



 

2. Click the Data tab, and then select the Sort command. 

 

3. The Sort dialog box will appear. Select the first column you want to sort by. In this example, we will 

sort by T-Shirt Size (column D) with the custom list we previously created for the Order field. 

4. Click Add Level to add another column to sort by. 



 

5. Select the next column you want to sort by, and then click OK. In our example, we'll sort 

by Homeroom # (column A). 

 

6. The worksheet will be sorted according to the selected order. In our example, the orders are sorted by 

T-shirt size. Within each group of T-shirt sizes, students are sorted by homeroom number. 



 

 

If you need to change the order of a multilevel sort, it's easy to control which column is sorted 

first. Simply select the desired column, and then click the Move Up or Move Down arrow to 

adjust its priority. 

 

 

 



 

Filtering Data: If your worksheet contains a lot of content, it can be difficult to find information 

quickly. Filters can be used to narrow down the data in your worksheet, allowing you to view only the 

information you need. 

To filter data:  In our example, we'll apply a filter to an equipment log worksheet to display only the laptops and 

projectors that are available for checkout. 

1. In order for filtering to work correctly, your worksheet should include a header row, which is used to 

identify the name of each column. In our example, our worksheet is organized into different columns 

identified by the header cells in row 1: ID#, Type, Equipment Detail, and so on. 

 

2. Select the Data tab, and then click the Filter command. 

 

3. A drop-down arrow will appear in the header cell for each column. 

4. Click the drop-down arrow for the column you want to filter. In our example, we will filter 

column B to view only certain types of equipment. 



 

5. The Filter menu will appear. 

6. Uncheck the box next to Select All to quickly deselect all data. 

 



7. Check the boxes next to the data you want to filter, and then click OK. In this example, we will 

check Laptop and Projector to view only these types of equipment. 

 

8. The data will be filtered, temporarily hiding any content that doesn't match the criteria. In our example, 

only laptops and tablets are visible. 

 

Filtering options can also be accessed from the Sort & Filter command on the Hometab. 



 

To apply multiple filters:  Filters are cumulative, which means you can apply multiple filters to help narrow 

down your results. In this example, we've already filtered our worksheet to show laptops and projectors, and 

we'd like to narrow it down further to only show laptops and projectors that were checked out in August. 

1. Click the drop-down arrow for the column you want to filter. In this example, we will add a filter to 

column D to view information by date. 

 

2. The Filter menu will appear. 



3. Check or uncheck the boxes depending on the data you want to filter, then click OK. In our example, 

we'll uncheck everything except for August. 

 

4. The new filter will be applied. In our example, the worksheet is now filtered to show only laptops and 

tablets that were checked out in August. 

 



To clear a filter:   After applying a filter, you may want to remove—or clear—it from your worksheet so you'll 

be able to filter content in different ways. 

1. Click the drop-down arrow for the filter you want to clear. In our example, we'll clear the filter in 

column D. 

 

2. The Filter menu will appear. 

3. Choose Clear Filter from [COLUMN NAME] from the Filter menu. In our example, we'll 

select Clear Filter from "Checked Out". 

 

4. The filter will be cleared from the column. The previously hidden data will be displayed. 



 

To remove all filters from your worksheet, click the Filter command on the Data tab. 

 

Advanced filtering:   If you need a filter for something specific, basic filtering may not give you enough options. 

Fortunately, Excel includes many advanced filtering tools, including search, text, date, 

and number filtering, which can narrow your results to help find exactly what you need. 

To filter with search:   Excel allows you to search for data that contains an exact phrase, number, date, and more. 

In our example, we'll use this feature to show only Saris brand products in our equipment log. 

1. Select the Data tab, and then click the Filter command. A drop-down arrow will appear in the header 

cell for each column. Note: If you've already added filters to your worksheet, you can skip this step. 

2. Click the drop-down arrow for the column you want to filter. In our example, we'll filter column C. 



 

3. The Filter menu will appear. Enter a search term into the search box. Search results will appear 

automatically below the Text Filters field as you type. In our example, we'll type saris to find all Saris 

brand equipment. When you're done, click OK. 

 



4. The worksheet will be filtered according to your search term. In our example, the worksheet is now 

filtered to show only Saris brand equipment. 

 

To use advanced text filters: Advanced text filters can be used to display more specific information, like cells 

that contain a certain number of characters or data that excludes a specific word or number. In our example, 

we'd like to exclude any item containing the word laptop. 

1. Select the Data tab, and then click the Filter command. A drop-down arrow will appear in the header 

cell for each column. Note: If you've already added filters to your worksheet, you can skip this step. 

2. Click the drop-down arrow for the column you want to filter. In our example, we'll filter column C. 

 



3. The Filter menu will appear. Hover the mouse over Text Filters, and then select the desired text filter 

from the drop-down menu. In our example, we'll choose Does Not Contain to view data that does not 

contain specific text. 

 

4. The Custom AutoFilter dialog box will appear. Enter the desired text to the right of the filter, then 

click OK. In our example, we'll type laptop to exclude any items containing this word. 



 

5. The data will be filtered by the selected text filter. In our example, our worksheet now displays items 

that do not contain the word laptop. 

 

To use advanced number filters:    Advanced number filters allow you to manipulate numbered data in different 

ways. In this example, we'll display only certain types of equipment based on the range of ID numbers. 

1. Select the Data tab on the Ribbon, then click the Filter command. A drop-down arrow will appear in 

the header cell for each column. Note: If you've already added filters to your worksheet, you can skip 

this step. 

2. Click the drop-down arrow for the column you want to filter. In our example, we'll filter column A to 

view only a certain range of ID numbers. 



 

3. The Filter menu will appear. Hover the mouse over Number Filters, then select the desired number 

filter from the drop-down menu. In our example, we'll choose Between to view ID numbers between a 

specific number range. 

 

4. The Custom AutoFilter dialog box will appear. Enter the desired number(s) to the right of each filter, 

then click OK. In our example, we want to filter for ID numbers greater than or equal to 3000 but less 

than or equal to 6000, which will display ID numbers in the 3000-6000 range. 



 

5. The data will be filtered by the selected number filter. In our example, only items with an ID number 

between 3000 and 6000 are visible. 

 

 

 

 



1. The Custom AutoFilter dialog box will appear. Enter the desired date(s) to the right of each filter, and 

then click OK. In our example, we want to filter for dates after or equal to July 15, 2015, and before 

or equal to August 15, 2015, which will display a range between these dates. 

 

 

 

 

 

 

 Tables 

  

      Tables : Once you've entered information into your worksheet, you may want to format your data as 

a table. Just like regular formatting, tables can improve the look and feel of your workbook, and they'll also 

help you organize your content and make your data easier to use. Excel includes several tools and predefined 

table styles, allowing you to create tables quickly and easily. 

To format data as a table: 

1. Select the cells you want to format as a table. In our example, we'll select the cell range A2:D9. 

 

2. From the Home tab, click the Format as Table command in the Styles group. 



 

3. Select a table style from the drop-down menu. 

 

4. A dialog box will appear, confirming the selected cell range for the table. 

5. If your table has headers, check the box next to my table has headers, and then click OK. 

 

6. The cell range will be formatted in the selected table style. 



 

Tables include filtering by default. You can filter your data at any time using thedrop-down 

arrows in the header cells. To learn more, review our lesson on Filtering Data. 

 

Modifying tables 

It's easy to modify the look and feel of any table after adding it to a worksheet. Excel includes 

many different options for customizing a table, including adding rows or columns and 

changing the table style. 

To add rows or columns to a table: 

If you need to fit more content into your table, Excel allows you to modify the table size by 

including additional rows and columns. There are two simple ways to change the table size: 

 Enter new content into any adjacent row or column. The row or column 

will be roped into the table automatically. 

http://www.gcflearnfree.org/excel2016/filtering-data/1/


 

 Click and drag the bottom-right corner of the table to create additional 

rows or columns. 

 



To change the table style: 

1. Select any cell in your table, and then click the Design tab. 

 

2. Locate the Table Styles group, and then click the more drop-down arrow to see all available table 

styles. 

 

3. Select the desired table style. 

 

4. The table style will be applied. 



 

To modify table style options: 

You can turn various options on or off to change the appearance of any table. There are six 

options: Header Row, Total Row, Banded Rows, First Column, Last Column, and Banded 

Columns. 

1. Select any cell in your table, then click the Design tab. 

2. Check or uncheck the desired options in the Table Style Options group. In our example, we'll 

check Total Row to automatically include a total for our table. 

 

3. The table style will be modified. In our example, a new row has been added to the table with 

a formula that automatically calculates the total value of the cells in column D. 



 

Depending on the type of content you have—and the table style you've chosen—these options 

can affect your table's appearance in various ways. You may need to experiment with a few 

different options to find the exact style you want. 

To remove a table: 

It's possible to remove a table from your workbook without losing any of your data. However, 

this can cause issues with certain types of formatting, including colors, fonts, and banded 

rows. Before you use this option, make sure you're prepared to reformat your cells if necessary. 

1. Select any cell in your table, and then click the Design tab. 

2. Click the Convert to Range command in the Tools group. 

 

3. A dialog box will appear. Click Yes. 



 

4. The range will no longer be a table, but the cells will retain their data and formatting. 

 

To restart your formatting from scratch, click the Clear command on the Home tab. Next, 

choose Clear Formats from the menu. 



 

 

 Understanding Track Changes 

When you turn on the Track Changes feature, every cell you edit will be highlightedwith a 

unique border and indicator. Selecting a marked cell will show the details of the change. This 

allows you and other reviewers to see what's been changed before accepting the revisions 

permanently. 

In the image below, each edited cell has a blue border and a small triangle in the upper-left 

corner. 



 

There are some changes Excel cannot track. Before using this feature, you may want to review 

Microsoft's list of changes that Excel does not track or highlight. 

You cannot use Track Changes if your workbook includes tables. To remove a table, select it, 

click the Design tab, then click Convert to Range. 

To turn on Track Changes: 

1. From the Review tab, click the Track Changes command, then select Highlight Changes from the 

drop-down menu. 

 

2. The Highlight Changes dialog box will appear. Check the box next to Track changes while editing. 

Verify that the box is checked for Highlight changes on screen, then click OK. 

http://office.microsoft.com/en-us/excel-help/track-changes-in-a-shared-workbook-HP010342961.aspx#BM7


 

3. If prompted, click OK to allow Excel to save your workbook. 

 

4. Track Changes will be turned on. A triangle and border color will appear in any cell you edit. If 

there are multiple reviewers, each person will be assigned a different color. 

5. Select the edited cell to see a summary of the tracked changes. In our example below, we've changed 

the content of cell D14 from ? to Getting to know your team. 

 



When you turn on Track Changes, your workbook will be shared automatically. Shared 

workbooks are designed to be stored where other users can access and edit the workbook at the 

same time, such as a network. However, you can also track changes in a local or personal copy, 

as seen throughout this lesson. 

To list changes on a separate worksheet: 

You can also view changes on a new worksheet, sometimes called the Tracked Changes 

history. The history lists everything in your worksheet that has been changed, including 

the old value (previous cell content) and the new value (current cell content). 

1. Save your workbook. 

2. From the Review tab, click the Track Changes command, then select HighlightChanges from the 

drop-down menu. 

 

3. The Highlight Changes dialog box will appear. Check the box next to List changes on a new sheet, 

then click OK. 



 

4. The tracked changes will be listed on their own worksheet, called History. 

 

 

To remove the History worksheet from your workbook, you can either save your workbook 

again or uncheck the box next to List changes on a new sheet in the 

Highlight Changes dialog box. 

Reviewing changes 

Tracked changes are really just suggested changes. To become permanent, the changes must 

be accepted. On the other hand, the original author may disagree with some of the tracked 

changes and choose to reject them. 



To review tracked changes: 

1. From the Review tab, click Track Changes, then select Accept/Reject Changesfrom the drop-down 

menu. 

 

2. If prompted, click OK to save your workbook. 

3. A dialog box will appear. Make sure the box next to the When: field is checked and set to Not yet 

reviewed, then click OK. 

 

4. A dialog box will appear. Click Accept or Reject for each change in the workbook. Excel will move 

through each change automatically until you have reviewed them all. 

 



5. Even after accepting or rejecting changes, the tracked changes will still appear in your workbook. To 

remove them completely, you'll need to turn off Track Changes. From the Review tab, click Track 

Changes, then select Highlight Changes from the drop-down menu. 

 

6. A dialog box will appear. Uncheck the box next to Track changes while editing, then click OK. 

 

7. Click yes to confirm that you want to turn off Track Changes and stop sharing your workbook. 

 

To accept or reject all changes at once, click Accept All or Reject All in the Accept or Reject 

Changes dialog box. 



Turning off Track Changes will remove any tracked changes in your workbook. You will not 

be able to view, accept, or reject changes; instead, all changes will be accepted automatically. 

Always review the changes in your worksheet before turning off Track Changes. 

 

1.  

Pivot tables 

In this example, because the data is limited and simple I am going to go for DATA CONSOLIDATION. 

If you have managed to bring all the worksheets into a single workbook then it’s worth naming each range as it 

makes referencing the data a bit simpler. However, it’s not a problem if you can’t as you can easily pick out 

ranges from separate worksheets and workbooks. 

Click in a blank cell below or to the right of any existing tables or on a blank sheet. This is important otherwise 

you could end up overwriting a data table by accident when you create the consolidated table. 

Go to the DATA tab and click on; 

 
This will open the CONSOLIDATE window; 

 

Data Consolidation window 

At the top you have the option to choose from a list of functions. These are all the usual 

functions; SUM, AVERAGE, COUNT, MAX,MIN etc. Select the appropriate function for what you are 

trying to achieve. In this case I want to add up all the hours people have completed so I’d go for SUM. 

Then you need to select all the tables that people have filled out for you. Make sure you include all row and 

column headings. 

Click on the range selection button….. 
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…and then select the ranges. After selecting a range of cells, click on ADD to add it to you references list. If 

you forget to do this (and it’s easily done….I’ve done it many times myself) your consolidation will not 

happen. So whenever you are consolidating repeat to yourself “Select…..add, select….add”. 

Keep going until all the table ranges have been added. 

 
Now for the important bit. At the bottom of the CONSOLIDATION window there are two little tick boxes. 

 

You need to tick at least one of these so that the end result shows you some labels associated with the data you 

have just consolidated. In this example I want to see both the days and the project numbers against the number 

of total hours, so here I would tick both boxes. You may well find that in most cases you will do so this 

anyway. 

Click on OK and there you have your consolidated data! 

 

 

 

 

 

 

MATHEMATICAL FUNCTIONS IN MS-EXCEL 

Functions What it Does 

SUM Adds its arguments 

SUMPRODUCT The most powerful and useful function in Excel 

ROUND Rounds a number to a specified number of digits 
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ROUNDUP Rounds a number up, away from zero 

SUBTOTAL Returns a subtotal of a filtered list or database) 

TRUNC Truncates a number to an integer 

INT Rounds a number down to the nearest integer) 

ABS Returns the absolute value of a number 

MOD Returns the remainder from division 

POWER Returns the result of a number raised to a power 

SQRT Returns a positive square root 

In Excel 2007 and Up 

SUMIFS 
Adds the cells specified by one or many given criteria 

(SUMPRODUCT does better 

SUM 

=SUM(A1,B6,G6) or =SUM(A1+B6+G6) will return the sum of the values in cells A1, B6 and G6 

=SUM(A1:A23) will return the sum of the values in cells A1 to A23 

=SUM(A1:A23,F3:F34) will return the sum of the values in cells A1 to A23 plus the sum of the values in cells 

F3  to F34 

In cell B2 of a yearly summary you want to sum the values in cells B2 of each of the monthly sheets. You have 

named your sheets "January" , "February" ....and you have 

used:=January!B2+February!B2+March!B2...+December!B2 

You can also write this:=SUM(January:December!B2) 

TRUNC 

I don't use the INT or ROUNDDOWN functions because TRUNC does the same thing and more. The TRUNC 

function removes decimals without rounding. If you have 2.2 or 2.7 in cell A1 =TRUNC(A1,0) will return 2. 

Interestingly enough if you have 12,345 in B1 using a minus sign in the second argument of 

TRUNC=TRUNC(B1,-3) will return  (12,000). Handy when you don't want to show the hundreds, the tens and 

units in a report. 

ROUND 

This function removes decimals rounding up the last decimal if the next one is 5 or over. So if you have 4.126 

in cell A1 and use the formula =ROUND(A1,2) the result will be 4.13 if the value in A1 is 4.123 the result will 

be 4.12. 

ROUNDUP 

This function does the same thing as the function ROUND but always rounds up. So if you have 4.126 in cell 

A1 and use the formula =ROUNDUP(A1,2) the result will be 4.13 if the value in A1 is 4.123 the result will 

still be 4.13. 



ABS 

=ABS(A1) will return 5 if in cell A1 you have -5 or 5. This functions removes the sign. 

MOD 

The modulo is what is left after a division. =MOD(20,6) is 2 because you have 3 times 6 in 20 and the rest is 2. 

Notice the use of the comma to separate the arguments. See an application below in determining the age of a 

person. 

SUMPRODUCT 

let’s say that you have a series of quantities in cells A1 to A5 and a series of unit prices in B1 to B5. With 

SUMPRODUCT you can calculate total sales with this formula: =SUMPRODUCT (A1:A5, B1:B5) 

Basically SUMPRODUCT sums A1 multiplied by B1 plus A2 multiplied by B2......... 

In the last 20 years I have used SUMPRODUCT for the purpose presented by Excel once or twice. But I use 

SUMPRODUCT daily to solve all kinds of other business data problems. It is the most powerful and useful 

function in Excel.  

SUBTOTAL 

The function SUBTOTAL allows (among other operations) to count, to sum or to calculate the average of 

filtered elements of a database. The function requires two arguments, the second is the range covered by the 

function and the first is a number between "1" and "11" that specifies the operation to be executed (for ex. "1" 

is for average, "2" is for count and "9" is for sum). 

=SUBTOTAL (9,B2:B45) 

SQRT 

Extracting a square root is finding the number that multiplied by itself will result in the number that you are 

testing. Extracting a cubic  root is finding the number that multiplied by itself two times will result in the 

number that you are testing. Extracting the  fourth  root is finding the number that multiplied by itself 3 times 

will result in the number that you are testing. 

To extract the square root of a number you will use a formula like: 

=SQRT(16) that will result in 4 because 4 multiplied by 4 is 16 or 

=SQRT(A1) that will also result in 4  if the value in cell A1 is 16. 

There are no specific Excel function to extract the cubic root or any other root. You have to trick the POWER 

function into doing it. 

POWER 

You can raise a number to a power (multiplying it by itself a certain number of times with this function. 

Hence: 

=POWER(4,2) will result in 16  (4 times 4) or 

=POWER(A1,2) will also result in 16  if the value in cell A1 is 4. 



You can  to trick the POWER function into extracting the square root, the cubic root and any other root by 

submitting a fraction as second argument. For example you can extract the square root of 16 with the 

formula=POWER(16,1/2), the cubic root with =POWER(16,1/3) and so on.  

ROUND, SUM 

=ROUND(SUM(A1:A5),2) will return the sum of A1 to A5 rounded to 2 decimals. 

IF, MOD, TRUNC and &  

How many dozens are there in 106 units? 

With the number of units in cell A1 the formulas in B1: 

=TRUNC(A1/12,0) will return the number of   complete dozens 

this formula in C1: 

=MOD(A1,12) will return the number of units left when the total number is divided by 12.  

If you want to present the result as "8 dozens and 10  units" in a single cell you will use the following 

formula combining math & Trig functions and the ampersand (& ) sign: 

=TRUNC(A1/12) & "dozens and " & MOD(A1,12) & " units"  

But what if there are 96 units and you don't want the result to show as "8 dozens and 0  units" but as "8 dozens" 

. You will then use this formula: 

=IF(MOD(A1,12)=0,TRUNC(A1/12) & " dozens" ,TRUNC(A1/12) & " dozens and " & MOD(A1 12) & 

" units" ) 

INT, TRUNC, MOD and &  
You want to determine the age of a person. If in cell " A3" you enter the date of birth, and in cell " B3" today's 

date, the following formula in " C3" would give you a good approximation of the age (plus or minus a few 

days): 

=INT((B3-A3)/365) & " years and " & TRUNC((MOD((B3-A3) 365))/30) & " months" 

If in cell A3 you enter the date of birth  and in B3 you enter the formula =NOW() then each day when  you 

open the workbook the age of the person is re-calculated in cell C3. 
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